logo

Knowledge Is Power

 
 

- Reinit des nouveaux posts -

- Recherche -

Messages Privés - Derniers posts
S'enregistrer - Login - Liste des membres
Vous logger : Login Pass

Unix-like >> Damn small linux -> PCMCIA Newtopic | Reply
poster txt
casskroot
Inscrit le 01-11-2003
Posté le 24-10-2007 20:28

Salut les enfants, je viens vous voir parce que j'ai récupéré un vieux PC portable et j'ai installé DSL-n ( http://damnsmalllinux.org/dsl-n/ ) et j'ai quelques soucis pour utiliser une carte wifi PCMCIA.
Le problème est le suivant: si je fais un lspci, aucune trace du périphérique:

lspci
0000:00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:11.0 CardBus bridge: Texas Instruments PCI1225 (rev 01)
0000:00:11.1 CardBus bridge: Texas Instruments PCI1225 (rev 01)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage LT Pro AGP-133 (rev dc)


Pourtant, si je fais un cardctl, il trouve bien la carte:
cardctl info
Socket 0:
product info: "Broadcom", "802.11g PCMCIA", "8.0"
manfid: 0x02d0, 0x0425
function: 6 (network)
Socket 1:
no product info available


(Il s'agit d'une carte wifi de freebox, avec un chipset broadcom 4306)

Après avoir pas mal tourné en rond, je me suis résolu à installer win 2000 pour voir si le problème n'était pas matériel et ce n'est pas le cas, j'ai réussi à configurer la carte sous windows sans problème (une fois le bon driver trouvé ).

un petit lspci -v et un dmesg si jamais ça peut vous aider à m'aider
lspci -v
0000:00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
Subsystem: Compaq Computer Corporation Armada 1750 Laptop System Chipset
Flags: bus master, medium devsel, latency 64
Memory at 50000000 (32-bit, prefetchable) [size=64M]
Capabilities: <available only to root>

0000:00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03) (prog-if 00 [Normal decode])
Flags: 66MHz, medium devsel
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: 00001000-00001fff
Memory behind bridge: 40000000-410fffff

0000:00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
Flags: bus master, medium devsel, latency 0

0000:00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 [Master])
Flags: bus master, medium devsel, latency 64
I/O ports at 2020 [size=16]

0000:00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 [UHCI])
Flags: bus master, medium devsel, latency 64, IRQ 11
I/O ports at 2000 [size=32]

0000:00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
Flags: medium devsel, IRQ 9

0000:00:11.0 CardBus bridge: Texas Instruments PCI1225 (rev 01)
Subsystem: Compaq Computer Corporation Armada E500
Flags: bus master, medium devsel, latency 168, IRQ 11
Memory at 7fffe000 (32-bit, non-prefetchable) [size=4K]
Bus: primary=00, secondary=02, subordinate=05, sec-latency=176
Memory window 0: 06000000-063ff000 (prefetchable)
Memory window 1: 06400000-067ff000
I/O window 0: 00004000-000040ff
I/O window 1: 00004400-000044ff
16-bit legacy interface ports at 0001

0000:00:11.1 CardBus bridge: Texas Instruments PCI1225 (rev 01)
Subsystem: Compaq Computer Corporation Armada E500
Flags: bus master, medium devsel, latency 168, IRQ 11
Memory at 7ffff000 (32-bit, non-prefetchable) [size=4K]
Bus: primary=00, secondary=06, subordinate=09, sec-latency=176
Memory window 0: 06800000-06bff000 (prefetchable)
Memory window 1: 06c00000-06fff000
I/O window 0: 00004800-000048ff
I/O window 1: 00004c00-00004cff
16-bit legacy interface ports at 0001

0000:01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage LT Pro AGP-133 (rev dc) (prog-if 00 [VGA])
Subsystem: Compaq Computer Corporation 3D Rage LT Pro (Compaq Armada 1750)
Flags: bus master, stepping, medium devsel, latency 66, IRQ 11
Memory at 40000000 (32-bit, non-prefetchable) [size=16M]
I/O ports at 1000 [size=256]
Memory at 41000000 (32-bit, non-prefetchable) [size=4K]
Capabilities: <available only to root>

dmesg
[i]ating delay loop... 655.36 BogoMIPS (lpj=327680)
Security Framework v1.0.0 initialized
SELinux: Disabled at boot.
Mount-cache hash table entries: 512
CPU: After generic identify, caps: 0183f9ff 00000000 00000000 00000000 00000000 00000000 00000000
CPU: After vendor identify, caps: 0183f9ff 00000000 00000000 00000000 00000000 00000000 00000000
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
CPU: After all inits, caps: 0183f9ff 00000000 00000000 00000040 00000000 00000000 00000000
Enabling fast FPU save and restore... done.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
ACPI: setting ELCR to 0200 (from 0800)
CPU0: Intel Mobile Pentium II stepping 0a
SMP motherboard not detected.
Local APIC not detected. Using dummy APIC emulation.
Brought up 1 CPUs
CPU0 attaching sched-domain:
domain 0: span 00000001
groups: 00000001
NET: Registered protocol family 16
EISA bus registered
PCI: PCI BIOS revision 2.10 entry at 0xf0484, last bus=1
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20050309
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [C000] (0000:00)
PCI: Probing PCI hardware (bus 00)
Boot video device is 0000:01:00.0
ACPI: PCI Interrupt Routing Table [\_SB_.C000._PRT]
ACPI: PCI Interrupt Link [C0F2] (IRQs *11)
ACPI: PCI Interrupt Link [C0F6] (IRQs *11)
ACPI: Power Resource [C103] (on)
ACPI: Power Resource [C105] (on)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 17 devices
PnPBIOS: Disabled by ACPI PNP
SCSI subsystem initialized
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
pnp: 00:05: ioport range 0x250-0x257 has been reserved
pnp: 00:0e: ioport range 0x4d0-0x4d1 has been reserved
pnp: 00:0e: ioport range 0x800-0x87f has been reserved
pnp: 00:0e: ioport range 0xd00-0xd0f has been reserved
pnp: 00:0e: ioport range 0xf00-0xf41 could not be reserved
audit: initializing netlink socket (disabled)
audit(1193242891.073:0): initialized
Total HugeTLB memory allocated, 0
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
Initializing Cryptographic API
Limiting direct PCI/PCI transfers.
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
PNP: PS/2 Controller [PNP0303:C0A8,PNP0f0e:C0A9] at 0x60,0x64 irq 1,12
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
RAMDISK driver initialized: 16 RAM disks of 100000K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller at PCI slot 0000:00:07.1
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0x2020-0x2027, BIOS settings: hda:DMA, hdb:DMA
Probing IDE interface ide0...
hda: IBM-DADA-26480, ATA DISK drive
hdb: UJDA150, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
Probing IDE interface ide2...
Probing IDE interface ide3...
Probing IDE interface ide4...
Probing IDE interface ide5...
hda: max request size: 128KiB
hda: 12685680 sectors (6495 MB) w/460KiB Cache, CHS=13424/15/63
hda: cache flushes not supported
hda: hda1 hda2 hda3
hdb: ATAPI 24X CD-ROM drive, 128kB Cache
Uniform CD-ROM driver Revision: 3.20
libata version 1.11 loaded.
mice: PS/2 mouse device common for all mice
EISA: Probing bus 0 at eisa.0
Cannot allocate resource for EISA slot 1
Cannot allocate resource for EISA slot 2
EISA: Detected 0 cards.
NET: Registered protocol family 2
IP: routing cache hash table of 256 buckets, 4Kbytes
TCP established hash table entries: 4096 (order: 4, 65536 bytes)
TCP bind hash table entries: 4096 (order: 3, 49152 bytes)
TCP: Hash tables configured (established 4096 bind 4096)
NET: Registered protocol family 1
NET: Registered protocol family 15
ACPI wakeup devices:
C059 C05A
ACPI: (supports S0 S3 S4 S4bios S5)
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 296k freed
input: AT Translated Set 2 keyboard on isa0060/serio0
Synaptics Touchpad, model: 1, fw: 4.3, id: 0x8e58a1, caps: 0x0/0x0
input: SynPS/2 Synaptics TouchPad on isa0060/serio1
ts: Compaq touchscreen protocol output
Generic RTC Driver v1.07
spurious 8259A interrupt: IRQ7.
ACPI: AC Adapter [C0CC] (off-line)
ACPI: Battery Slot [C0D6] (battery present)
ACPI: Battery Slot [C0D7] (battery absent)
ACPI: Lid Switch [C108]
ACPI: Sleep Button (CM) [C059]
ACPI: Power Button (CM) [C05A]
ACPI: Fan [C102] (on)
ACPI: Fan [C104] (on)
ACPI: CPU0 (power states: C1[C1] C2[C2])
ACPI: Processor [C098] (supports 8 throttling states)
ACPI: Thermal Zone [C106] (67 C)
Linux Kernel Card Services
options: [pci] [cardbus] [pm]
ACPI: PCI Interrupt Link [C0F2] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:00:11.0[A] -> Link [C0F2] -> GSI 11 (level, low) -> IRQ 11
Yenta: CardBus bridge found at 0000:00:11.0 [0e11:b121]
Yenta: Using CSCINT to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:00:11.0, mfunc 0x01001c72, devctl 0x64
Yenta: ISA IRQ mask 0x0498, PCI irq 11
Socket status: 30000010
ACPI: PCI Interrupt 0000:00:11.1[A] -> Link [C0F2] -> GSI 11 (level, low) -> IRQ 11
Yenta: CardBus bridge found at 0000:00:11.1 [0e11:b121]
Yenta: Using CSCINT to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:00:11.1, mfunc 0x01001c72, devctl 0x64
Yenta: ISA IRQ mask 0x0498, PCI irq 11
Socket status: 30000006
cs: IO port probe 0xc00-0xcff: clean.
cs: IO port probe 0xc00-0xcff: clean.
cs: IO port probe 0x820-0x8ff: clean.
cs: IO port probe 0x820-0x8ff: clean.
cs: IO port probe 0x800-0x80f: clean.
cs: IO port probe 0x800-0x80f: clean.
cs: IO port probe 0x100-0x4ff: excluding 0x100-0x107 0x220-0x22f 0x330-0x337 0x378-0x37f 0x388-0x38f 0x3e8-0x3ff
cs: IO port probe 0x100-0x4ff: excluding 0x100-0x107 0x220-0x22f 0x330-0x337 0x378-0x37f 0x388-0x38f 0x3e8-0x3ff
cs: IO port probe 0xa00-0xaff: clean.
cs: IO port probe 0xa00-0xaff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
usbcore: registered new driver usbfs
usbcore: registered new driver hub
USB Universal Host Controller Interface driver v2.2
ACPI: PCI Interrupt Link [C0F6] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:07.2[D] -> Link [C0F6] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:07.2: Intel Corporation 82371AB/EB/MB PIIX4 USB
uhci_hcd 0000:00:07.2: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:07.2: irq 11, io base 0x00002000
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.01:USB HID core driver
ieee1394: Initialized config rom entry `ip1394'
Serial: 8250/16550 driver $Revision: 1.90 $ 14 ports, IRQ sharing disabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS2 at I/O 0x3e8 (irq = 4) is a 16550A
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,EPP]
piix4_smbus 0000:00:07.3: Found 0000:00:07.3 device
piix4_smbus 0000:00:07.3: Host SMBus controller not enabled!
Linux agpgart interface v0.101 (c) Dave Jones
cloop: Initializing cloop v2.02
cloop: loaded (max 64 devices)
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)
apm: overridden by ACPI.


J'ai tenté un coup de setpci comme expliqué sur cette page mais ça n'a rien change (j'avais déjà des valeurs de SUBORDINATE_BUS supérieures à 3). J'ai pas tenté l'application du patch (si mes souvenirs sont bons, j'ai un noyau 2.6.12).

Merci d'avance si vous pouvez m'aider.


A plus.



PS: putain de session time-out, y'a pas moyen d'ajouter un javascript qui prévient avec une message box quand on est resté trop longtemps sur la même page ?

_________________________


[ Ce Message a été édité par: casskroot le 2007-10-24 20:32 ]
profil | mail | edit | quote
ganza
Inscrit le 10-02-2007
Avatar
Posté le 25-10-2007 06:22

Je ne suis pas un pro de nux, mais bon on ne sait jamais..

Déjà, je pense que tu devrai être root pour faire tes tests, ça peut aider à obtenir plus d'infos.
(ce qui me fait dire que tu n'était pas loggué sous root ? :
Memory at 50000000 (32-bit, prefetchable) [size=64M]
Capabilities: <available only to root>
)

Ensuite, c'est effectivement chelou que tu ne vois pas une ligne avec "14e4:" (signature de la BC4306) avec lspci.

Mais y'a un autre pb: d'après ce que j'ai trouvé sur le site du mec qui a ecrit le driver le plus utilisé pour la 4306 (http://bcm43xx.berlios.de/), un noyau 2.6.16-rc2 minimum est nécessaire.. or DSL-N = 2.6.12

Il semblerai egalement que pplusieurs mecs ai réussi a faire marcher cette carte avec Puppy (une autre distrib) et pas avec DSL-n.. D'une manière générale, Puppy semble mieux pour les vieux ordis.

Bonne chance..
_________________________
“Time you enjoy wasting, was not wasted at all.” - John Lennon
profil | edit | quote
casskroot
Inscrit le 01-11-2003
Posté le 25-10-2007 08:05

j'ai pas fais le lspci (v en root mais ça change rien à mes tests, les commandes pour lesquelles c'est nécessaire ont été faites en root.

Pour ce qui est des drivers bcm43xx, en effet, ils sont intégrés au noyau à partir de la version 2.6.17-rc2 mais c'est pas ça le problème, même sans pilotes, je devrais quand même voir ma carte apparaitre et je comptais me servir de ndiswrapper dans un premier temps avant de recompiler un noyau (parce que là pour pas avoir un truc qui fait complètement ramer mon PC, va falloir que je passe 3 jours à sélectionner uniquement ce dont j'ai besoin).

Je connais pas encore Puppy, je vais y jeter un oeil, je te remercie pour cette info .


PS: le problème à mon avis ne se situe pas au niveau de la carte wifi mais du controleur TI1225. J'ai trouvé pas mal de problèmes avec ce controleur sur bugtraq ou autre mais j'ai pas pour autant réussi à résoudre mon problème.
_________________________

profil | mail | edit | quote
casskroot
Inscrit le 01-11-2003
Posté le 25-10-2007 12:20

Bon c'est la même histroie sous puppy.

J'ai booté avec knoppix pour voir ce que ça donnait (j'ai peur de rien ).
noyau 2.6.19
lspci n'est pas plus bavard.
dans le KInfoCenter, pour les périphériques PCMCIA, il m'indique qu'il y a un périphérique non supporté.
J'ai installé bcm43xx-fwcutter, installé le firmware, chargé le module bcm43xx et toujours rien de nouveau.

Je commence un peu à désespérer.



edit: à votre avis, le problème se situe au niveau du controlleur ou du périphérique (j'ai pas d'autre périphérique PCMCIA pour tester) ?


_________________________


[ Ce Message a été édité par: casskroot le 2007-10-25 12:43 ]
profil | mail | edit | quote
casskroot
Inscrit le 01-11-2003
Posté le 28-10-2007 15:36

Personne pour répondre à ma dernière question ?
_________________________

profil | mail | edit | quote
Newtopic | Reply

Online : ajodegabozub, Apokoalojes, azuuonmugheot, CharlesJaw, eakeqothozo, ekicutjumur, enlosamajuwax, eqerureuxe, ideuriimi, iphuikeva, ocefesepaluja, ujiwora, unuhodib, upeiwez, urodenajoraf, urubewisaqi, uwamiqonuh, uyyijubuaxci, WernerKef et 123 Guests


Retour Index NewFFR Repository : http://taz.newffr.com
Cagades à Stick : http://alcane.newffr.com
Forum HTML et Archive -> ici
ForumFR Sql/Xml (2006/04) (SF pas à jour du tout...) - Alive since 2001 Newffr.com
Pour toute plainte ou problème -> Contacter Borax, Hyatus, Tweakie ou Stick par message privé (ou Gueulez sur le forum :) )
Retour haut de page